Skip to main content
Previous section

Supported Version Interoperability

This section describes supported interoperability between different versions of InterSystems products.

Version Interoperability Table

The following table shows the cross-version compatibility of this release with the most recent releases of InterSystems products.

For example, a Caché 2018.1 instance can be the shadow destination of Caché 5.1 (or later) servers; conversely, only Caché 2007.1 (or later) instances can be the shadow destination of journal files created on 2018.1 servers.

Note:

Mixed Caché clusters including Caché 5.2 (or earlier) and 2007.1 (or later) servers are not supported.

Component Client/Destination Server/Source
CSP Gateway4 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1 2018.1 or earlier
ECP1 5.1, 5.2, 2007.1, 2008.1, 2008.2, 2009.1, 2010.1, 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1 5.1, 5.2, 2007.1, 2008.1, 2008.2, 2009.1, 2010.1, 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1
Backup Restore 2007.1, 2008.1, 2008.2, 2009.1, 2010.1, 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1 5.0, 5.1, 5.2, 2007.1, 2008.1, 2008.2, 2009.1, 2010.1, 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1
Journal Restore 2007.1, 2008.1, 2008.2, 2009.1, 2010.1, 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1 5.0, 5.1, 5.2, 2007.1, 2008.1, 2008.2, 2009.1, 2010.1, 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1
Mirroring3 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1
Shadowing 2007.1, 2008.1, 2008.2, 2009.1, 2010.1, 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1 5.1, 5.2, 2007.1, 2008.1, 2008.2, 2009.1, 2010.1, 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1
Studio2 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1 2007.1, 2008.1, 2008.2, 2009.1, 2010.1, 2010.2, 2011.1, 2012.1, 2012.2, 2013.1, 2014.1, 2015.1, 2015.2, 2016.1, 2016.2, 2017.1, 2017.2, 2018.1
xDBC 5.0.13 or later 5.0.13 or later

1 An ECP application server that is connected to a mirrored data server must be version 2010.2 or later. To run any object-based application over ECP, the server and the clients must use the same product version.

2 Caché Studio is not forward compatible; it does not connect to systems with higher version numbers. The Caché Studio version on a client must be the same or later than the Caché server version to which it connects. This restriction does not apply to maintenance releases.

3 Only reporting async members can be of a different version than the other members of the mirror; in this table, Client/Destination refers to reporting async members and Server/Source to failover members and disaster recovery (DR) async members. The failover members of a mirror and any DR async members must all be of the same version, and can differ within the range of releases defined in this table only for the duration of one of the upgrade procedures described in Minimum Downtime Upgrade with Mirroring in the “Upgrading Caché” chapter of the Caché Installation Guide.

4 A mirror-aware CSP gateway can be configured only if the mirrored instance is version 2016.1 or later.

Supported Upgrade Paths

You can upgrade directly to this release of Caché from release 2009.1 or any later release. However, if you are upgrading a pre-2012.1 instance containing any 2K block size databases, these must be converted to 8K format before upgrading to version 2012.x or beyond, using the procedure described in Supported Upgrade Paths in the “Upgrading Caché” chapter of the Caché Installation Guide.

To upgrade from a version older than 2009.1, you must first upgrade to 2009.1 or later, then upgrade to the current release (using the procedure for converting 2K block size databases if applicable). For assistance with upgrading from earlier versions, contact the InterSystems Worldwide Response Center (WRC).